Liquid Web Live Chat Outage
Incident Report for Liquid Web - Services
Resolved
Our live chat systems are back up and running at this time.
Posted Nov 05, 2019 - 14:45 CST
Investigating
At this time we are experiencing issues with our Live Chat system. We are currently looking into this issue and will continue to update as more information is gathered.
Posted Nov 05, 2019 - 13:47 CST
This incident affected: Support Services (Chat Support).