Premium Business Email Control Panel Access & Webmail

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 06:09 EDT

Monitoring

A fix was implemented by our email vendor, and we are monitoring the results.

If you have any questions, don't hesitate to get in touch with a member of our support team via Chat or Case at my.liquidweb.com.
Posted Aug 20, 2025 - 17:23 EDT

Investigating

Our vendor has reported an issue with the Premium Business Email Control Panel and webmail. This may impact email management; however, it does not affect email sending or receiving through the email clients. The vendor is actively working toward full restoration, and further updates will be provided as they become available.

If you have any questions, don't hesitate to contact a member of our support team via live chat or Case.
Posted Aug 20, 2025 - 12:42 EDT
This incident affected: Business Email.