421 Misdirected requests after upgrading to CloudLinux's ea-apache24-2.4.64

Incident Report for Liquid Web - Services

Resolved

All previously impacted customers should have the fix applied. If for some reason your sites are still experiencing the HTTP 421 Misdirected Request error, please contact Support.
Posted Jul 29, 2025 - 18:00 EDT

Update

CloudLinux has released an updated version of ea-apache24 to the cl-ea4-testing repository to address this issue. For servers in which the packages are updated using Imunify360 Hardened repositories, we need to upgrade ea-apache24 from the beta repositories:

Please don’t hesitate to reach out to Support if you require any assistance with implementing these steps.
Posted Jul 28, 2025 - 02:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2025 - 07:57 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 26, 2025 - 07:57 EDT

Identified

CloudLinux recently updated their provided ea-apache24 to version 2.4.64, which has resulted in misdirected requests when combined with NGINX or other proxies. At this time, CloudLinux has confirmed they are reviewing this within their internal case EA4D-684.

Cpanel has suggested a workaround to downgrade ea-apache24 to version 2.4.63 via yum and also version lock the ea apache24 packages to prevent updates until the fixed package is released

Please feel free to contact Liquidweb support if you experience any issues or if you need any assistance with downgrading the version
Posted Jul 26, 2025 - 03:33 EDT
This incident affected: Cloud Dedicated, Cloud VPS Hosting, and CPanel.