Power Outage in Phoenix, AZ

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 20:25 EDT

Monitoring

Primary power has been restored, and we are monitoring the situation.
Posted Jul 16, 2026 - 16:02 EDT

Investigating

A subset of servers within our Phoenix, AZ data center lost power. Our on-site team is investigating.
Posted Jul 16, 2026 - 16:02 EDT
This incident affected: Data Centers (DC4 - PHX).