Premium Business Email Issue
Incident Report for Liquid Web - Services
Resolved
Our Premium Business Email vendor has updated that this issue has been resolved. The Incident is now closed and the hosted email system is operating as normal.
Posted Jun 30, 2021 - 12:37 CDT
Investigating
Currently our vendor is reporting that there is a number of users experiencing connectivity issues with the Premium Business Email environment, specifically webmail. Users may experience an error prompt upon logging in, navigating or sending messages. They are currently working toward full restoration at this time. More updates will be provided as the become available.
Posted Jun 30, 2021 - 07:38 CDT
This incident affected: Business Email.