Premium Business Email | Webmail Issues
Incident Report for Liquid Web - Services
Resolved
Our team has resolved this issue and webmail access has been restored.
Posted Nov 07, 2024 - 06:43 EST
Monitoring
Our team has resolved this issue and we're currently monitoring the status.
Posted Nov 07, 2024 - 06:23 EST
Investigating
We have received multiple reports that users are getting disconnected from email clients and/or being prompted to re-enter their credentials along with access issues over Webmail.

We are working with our email vendor to resolve the problem. We will provide updates here as more information becomes available.
Posted Nov 07, 2024 - 01:30 EST
This incident affected: Business Email.