Issues with Webmail URL https://webmail.liquidweb.services/
Incident Report for Liquid Web - Services
Resolved
Our email Engineers resolved the issue and webmail logins are now working.
Posted Mar 21, 2023 - 13:18 EDT
Monitoring
We have implemented a fix for the https://webmail.liquidweb.services url and are monitoring for any interruptions.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 20, 2023 - 19:23 EDT
Identified
We have received notification that issue has been identified and currently implementing a fix. Will update you with further information as we make progress.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 20, 2023 - 18:35 EDT
Update
We apologize for the length of time on this issue. We are still engaging our email Engineers for a full resolution on this, and have provided more information to aid in their troubleshooting.

We will provide updates as we have them.
Posted Mar 20, 2023 - 11:32 EDT
Investigating
We are seeing increased feedback that our branded webmail URL for https://webmail.liquidweb.services/ is having issues and is producing an error when customers attempt to login. It is intermittently not working.

We have been in direct contact with our email vendor and their Engineers are looking into the issue.

-- In the mean time, and as a work around, customers can use https://webmail.emailsrvr.com. We will provide updates as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 17, 2023 - 13:03 EDT
This incident affected: Business Email.