Business Email Disruption
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 26, 2019 - 17:37 CDT
Monitoring
A change has been implemented to resolve the issue. Webmail, IMAP, and POP3 connections are operating normally and mail delivery has returned to normal. We will continue to provide updates until this is resolved.
Posted about 2 months ago. Jun 26, 2019 - 17:17 CDT
Investigating
We are working with our vendor to investigate a disruption with their Email services.

Users will experience slowness when accessing their email. This includes slowness accessing webmail, loading messages, attachments, and connecting using IMAP and POP3. Users may also receive the below error in webmail:

[SERVERBUG] Internal error occurred. Refer to server log for more information.

Incoming email is impacted as well for all Hosted Email users.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted about 2 months ago. Jun 26, 2019 - 15:20 CDT
This incident affected: Business Email.