Premium Business Email Webmail login Issue
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 14:47 EST
Monitoring
A solution has been put in place by our email vendor. The issue of preventing access to the webmail portal has been resolved.

If you have any questions, don't hesitate to get in touch with a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jan 08, 2025 - 09:07 EST
Identified
Our email vendor has identified a likely cause and is working on a remediation step. We will update the status page as soon as we have confirmed progress.
Posted Jan 08, 2025 - 04:14 EST
Investigating
Our email vendor has identified an issue affecting Premium Business Email webmail login access. While email delivery remains unaffected, their engineering team is working to resolve the issue promptly. Users can access their email via POP/IMAP by configuring their email client using the following link: Here's the link to setup - https://emailhelp.rackspace.com/
Posted Jan 07, 2025 - 09:59 EST
This incident affected: Business Email.