Network Outage Impacting Support Services and Datacenters.
Incident Report for Liquid Web - Services
Resolved
All systems are stable and this incident is resolved at this time. If you have any further questions or concerns, please contact a member of our support team via live-chat, ticket, email (support@liquidweb.com) or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 23, 2024 - 09:05 EDT
Monitoring
Liquid Web Systems and Network Engineering teams have implemented changes to restore service to the network, and services are reporting online at this time. We are actively monitoring the network environment and will address network issues as they occur.

We appreciate your patience in the matter. If you are still experiencing any service impact, or if you have any questions or concerns, please contact a member of our support team via live-chat, ticket, email (support@liquidweb.com) or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 22, 2024 - 21:46 EDT
Identified
Our engineers have been able to identify the cause of the networking issue and are working on implementing changes to restore stability to the network. Our support services are stable at this time. Our team will continue to work on this to further stabilize the environment.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Jul 22, 2024 - 20:32 EDT
Investigating
Our team has been alerted to an issue impacting our Lansing and Southfield data centers, in addition to the liquid web management portal and the systems used by our support team to receive and answer phone calls. Our engineers are working as fast as possible to restore access to the impacted services and the support systems. We appreciate your understanding in this and will update this status page as we have more information.
Posted Jul 22, 2024 - 20:00 EDT
This incident affected: Support Services (Chat Support, Ticket Support, Phone Support), Network (LAN Network), and Management Portal.