Access to the Customer Portal has been restored, and functionality should now be coming back online. Our teams have applied the necessary fixes and will continue to closely monitor performance and stability to ensure the portal remains fully operational.
If you continue to experience any issues accessing the portal, please reach out to Support.
Thank you for your patience while we worked through this incident.
Posted Nov 19, 2025 - 11:24 EST
Update
Our teams are actively investigating and working to restore full functionality as quickly as possible.
In the meantime, clients can still open new support cases by emailing us directly at support@liquidweb.com, or by replying to a previous case via email for any new issues. Our Support Team will continue to assist from there.
Posted Nov 19, 2025 - 11:18 EST
Identified
Our team has identified the underlying issue impacting the Customer Portal and is working on a fix. Access may remain limited during this time. We will share another update shortly.
Posted Nov 19, 2025 - 11:06 EST
Investigating
We are currently experiencing an issue affecting access to the Customer Portal. Our teams are actively investigating the cause and working to restore full functionality as quickly as possible.
At this time, customers may be unable to log in, and instead will see a maintenance page upon logging in.
We will provide updates as soon as more information becomes available. We appreciate your patience while we work to resolve this.