Business Email Control Panel Service Interruption
Incident Report for Liquid Web - Services
Resolved
Our email vendor has resolved the status post for the Administrative Control Panel used to access email mailboxes and services. Customers are now able to access the control panel for email services through their customer portal, https://my.liquidweb.com.

If you have any further questions or concerns, please do not hesitate to contact a member of our support team by email at support@liquidweb.com, via live-chat or ticket through your customer portal (https://my.liquidweb.com/) or by phone, toll-free at 1-800-580-4985 or internationally at +1.517.322.0434.
Posted Jun 13, 2022 - 19:02 EDT
Monitoring
Our email vendor is investigating an interruption in service to the Administrative Control Panel used to access email mailboxes and services. Engineers have identified the issue and are working to resolve the service impact. During the interruption in service, customers will not be able to access the control panel for email services through their customer portal, https://my.liquidweb.com.

We will provide a further update once the service impact is confirmed resolved. If you have any further questions or concerns, please do not hesitate to contact a member of our support team by email at support@liquidweb.com, via live-chat or ticket through your customer portal (https://my.liquidweb.com/) or by phone, toll-free at 1-800-580-4985 or internationally at +1.517.322.0434.
Posted Jun 13, 2022 - 11:13 EDT
This incident affected: Business Email.