International Support Phone Number Connectivity

Incident Report for Liquid Web - Services

Resolved

The issue has been resolved. If you need immediate assistance, please contact a member of our support team by visiting us in live-chat or by calling 1-800-580-4985
Posted Jul 19, 2017 - 09:26 EDT

Investigating

We have identified an issue with our international number 517-322-0434 not connecting to our support teams.

We are working to resolve the issue and will provide updates when available. Support can still be contacted via our toll free number at 1-800-580-4985, our backup number at 517-679-0876, via LiveChat, or by sending emails to support@liquidweb.com.
Posted Jul 18, 2017 - 09:49 EDT