Premium Business Email Issue
Incident Report for Liquid Web - Services
Resolved
Our email vendor has marked the Incident as closed and has indicated that the hosted email system is operating as normal.
Posted Dec 16, 2021 - 16:06 CST
Monitoring
Our email vendor has reported their engineers have implemented a solution and are currently monitoring the issue. We will provide further updates as they become available.

Mail delivery is not impacted.
Posted Dec 15, 2021 - 10:12 CST
Investigating
Our email vendor is investigating reports of connectivity issues to the Exchange environment. Users may experience an error upon attempting to sign-in to their account via the Outlook Web App, as well as issues accessing their mailbox via IMAP and MAPI protocols. We will provide further updates as the become available.

Mail delivery is not impacted.
Posted Dec 14, 2021 - 11:56 CST