Business Email Disruption
Incident Report for Liquid Web - Services
Resolved
Our email vendor has reported a solution has been put in place and the incident is now closed.
Posted Oct 04, 2022 - 14:03 EDT
Investigating
Our email vendor is investigating reports of connectivity issues to the Hosted Email Environment. Users may experience an error upon accessing Webmail, attempting to sync mail to their email client and/or a prompt to re-enter their password.

We will provide further updates as the become available.
Posted Oct 04, 2022 - 10:46 EDT
This incident affected: Business Email.