My.Liquidweb portal issues

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Dec 31, 2025 - 14:25 EST

Monitoring

The access to my.liquidweb.com and https://login.liquidweb.com customer portals are functioning as expected at this time. We are monitoring the situation closely.

If you have any questions, please contact a member of our support team via live chat, ticket, or by phone at (800)-580-4985, or (517)-322-0434 (international).
Posted Dec 31, 2025 - 08:22 EST

Investigating

We are currently investigating an issue affecting access to the My.liquidweb.com portal. This status post will be updated as more information becomes available.

If you have any questions, don't hesitate to get in touch with a member of our support team via live chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Dec 31, 2025 - 07:51 EST
This incident affected: Management Portal.